Resolved
The degraded block producer has been rotated and the fix has been applied. The network is healthy again. We've confirmed the network has remained healthy and stable.
Investigating
Around 7:15 PM UTC we noticed degraded performance affecting block production on Polygon PoS Mainnet. Users may have experienced delayed transaction confirmations. We will provide updates as more information becomes available.