Amoyscan Explorer Degraded Service

Incident Report for Polygon

Resolved

The fix has been implemented and the issue is resolved.
Posted Feb 28, 2026 - 07:31 UTC

Investigating

We've identified that Amoyscan is currently experiencing issues related to the database services, which causes block data to not be updated to the latest state. The team is actively working on a resolution, and the fix is expected to take some time. We will share an update once the issue is resolved.

More details are available here: https://polygonscan.freshstatus.io/incident/1575885
Posted Feb 28, 2026 - 07:10 UTC
This incident affected: Block Explorers (Polygonscan Amoy).