Amoy Testnet – Erigon Performance Issue

Incident Report for Polygon

Resolved

The incident has been resolved and we continue to monitor
Posted Nov 16, 2025 - 06:01 UTC

Update

We are continuing to investigate this issue.
Posted Nov 16, 2025 - 06:01 UTC

Update

We're still investigating this issue and users may continue to see some unusual behaviour on the Erigon Amoy Testnet. We will provide further updates here once any fixes are rolled out.
Posted Nov 14, 2025 - 17:20 UTC

Investigating

We have identified an issue with Erigon on Amoy Testnet, and users may currently experience some temporary impacts to RPC provider endpoint responses. We are working on an immediate fix and will provide updates here when this is resolved.
Posted Nov 14, 2025 - 11:38 UTC