UPDATE: Hard fork has been successfully completed, and milestones are now processing normally along with state sync. Checkpoints are going through and consensus finalization has been fully restored on Polygon PoS.
We will continue to monitor the network closely to ensure everything continues to remain stable. Thank you for your patience!
Posted Sep 10, 2025 - 15:28 UTC
Update
UPDATE: Milestone fixes rolled out
We identified the cause of the finality issue and have rolled out v2.2.11-beta2 for Bor and v0.3.1 for Heimdall, with the latter a hardfork implemented at 3PM UTC.
This is a Heimdall hardfork release, scheduled for September 10th 2025, at around 15:00 UTC (block number 28525000)
We will continue to monitor the network to ensure all issues all resolved. Thank you for your patience.
Posted Sep 10, 2025 - 13:13 UTC
Update
Network Update – Issues impacting finality
Our team is actively investigating an issue with some nodes causing delays in block finality.
The chain is running, and blocks continue to be produced. You can track this here: https://bor-mainnet.vitwit.com/ Checkpoint finality is working as expected within 15mins.
We have identified a fix and it is being rolled out to all validators and service providers soon.
Posted Sep 10, 2025 - 08:52 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 10, 2025 - 08:07 UTC
Identified
Bor/Erigon are experiencing an ongoing issue with some RPCs causing delays in block finality. Some apps may experience disruptions. We have identified a bug preventing node progress and are actively debugging currently.
In the meantime, only some nodes are affected, but the chain is running, and blocks continue to be produced. You can track this here: https://bor-mainnet.vitwit.com/
Posted Sep 10, 2025 - 07:18 UTC
Monitoring
We see that a restart of nodes has fixed the issues for many validators and RPC providers.
While a few providers had to rewind to the last finalized block of 76273070 and currently syncing.
We are monitoring the issue and will keep posting updates here.
Posted Sep 10, 2025 - 05:34 UTC
Investigating
Bor/Erigon experienced a temporary disruption that led to a delay in finalization.
To be clear: the Polygon chain has remained live, but due to RPC issues, users may experience disruptions accessing various apps.
We are now actively collaborating with RPC providers to accelerate resolution and restore user-facing services.
Our team is fully engaged, and we’re confident in a swift return to normal service. Check back here for further updates.
Posted Sep 10, 2025 - 05:11 UTC
This incident affected: Block Explorers (OKLink Mainnet, Polygonscan Mainnet).