Polygon to Ethereum Asset Withdrawals Impacted

Incident Report for Polygon

Postmortem

On September 10, 2025, at 04:30 UTC, the Polygon network experienced a degradation in its milestone finalization mechanism.

 

A rare race condition between milestone processing and block importing caused an incompatible milestone to be recorded in some validator nodes, leading to extended delays in milestone based finality.

 

While blocks continued to be finalised via checkpoints, providing finality in around 20 minutes, a hard fork based fix was required to remediate the incorrect milestone, and restore usual milestone based finality (4 - 5 seconds). The network resumed normal operation following this emergency hard fork at 15:00.

 

Following a detailed post-mortem, the development team have released a new version of bor as an additional safety guards to prevent any reoccurrence. We advise upgrading to v2.2.11 to ensure continued compatibility and performance, detailed here: https://github.com/0xPolygon/bor/releases/tag/v2.2.11

Posted Sep 18, 2025 - 03:24 UTC

Resolved

Update: Polygon to Ethereum Withdrawals.

The incident impacting Polygon to Ethereum asset withdrawals has been fully resolved. All services are now operating normally. Users can now proceed ahead with their withdrawals on Polygon portal. If any issues feel free to reach out to our support team on support.polygon.technology

We appreciate your patience and understanding while we worked to resolve this issue.
Posted Sep 11, 2025 - 08:02 UTC

Identified

A temporary issue has been identified with the RPC services that is impacting asset withdrawals from Polygon to Ethereum, only on the Polygon Portal. Our Engineering team is actively working to restore normal operations as quickly as possible.

Asset withdrawals may be delayed, but no funds are at risk. We will provide updates here as the situation progresses.
Posted Sep 11, 2025 - 06:05 UTC
This incident affected: Polygon Portal.