Sporadic service degradation reported by a small number of RPC providers

Incident Report for Polygon

Postmortem

Problem: Some RPC providers and validators reported their Bor / Heimdall nodes stalled and unable to sync following the Phuket Heimdall hardfork.

Impact: A small number of third-party RPC providers and validators experienced node syncing stalls. There was no impact to network finality or liveliness, and most RPC nodes / providers experienced no disruption.

Causes: The Phuket Heimdall hardfork (0.7.0 Heimdall) caused some Bor / Heimdall nodes operated by a small number of RPC providers and validators to stall during syncing. This hard fork introduced an explicit dependency from Heimdall to Bor, so for more complex infrastructure where this dependency didn't exist (for example Heimdall didn't have Bor configured) or where the Bor node was not fully synced, Heimdall stalled.

Steps to resolve: A new release, heimdall-v2 v0.7.1, was made available to fix the syncing issue by removing this explicit dependency, allowing Heimdall to continue syncing even if it was not connected to a fully synced Bor node. Impacted providers upgraded and resynced their nodes, which resolved the problem for all major providers, and updates have been posted to inform stakeholders.

Posted May 06, 2026 - 15:28 UTC

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 20:18 UTC

Monitoring

A small number of third-party RPC providers reported sporadic service degradation earlier today. There was no impact to network finality or liveliness, and the majority of RPC providers operated normally throughout.

Affected providers are rolling out a fixed version. Early indicators show this is resolving the issue; rollout is still in progress.

Node operators experiencing a stuck node can resync by upgrading to heimdall-v2 v0.7.1-beta: https://github.com/0xPolygon/heimdall-v2/releases/tag/v0.7.1-beta

We're monitoring and will mark this resolved once all affected providers confirm full recovery.
Posted Apr 29, 2026 - 17:44 UTC