Polygon portal(Amoy)

Incident Report for Polygon

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 14:25 UTC

Identified

Date: July 21, 2025
Time: 10:10 UTC – Resolved on 30th July
Status: In Progress

Affected Services
https://portal.polygon.technology/bridge – Testnet only

Summary
As of 10:10 UTC on July 21, 2025, the testnet bridge on the Polygon Portal has been temporarily disabled. A banner was enabled on the site notifying users that testnet bridging is unavailable and expected to remain down until July 31.

Initial investigation suggests the issue is most likely related to RPC instability on the testnet Ethereum side, affecting the ability of backend indexers to track and validate cross-chain transactions.

Technical Overview
Ethereum Testnet RPC: Upstream RPC endpoints on the Ethereum testnet are exhibiting inconsistent responses, causing failures in bridge-related transaction monitoring and validation.

Testnet Bridge Backend: Due to unreliable source chain data from RPC calls, the bridge backend has been disabled to avoid stuck or failed transactions during this period.

Resolution
The issue is currently being worked on. The engineering team is investigating on improving failover handling. Services are expected to resume by July 31, 2025, pending RPC stability and internal validation. Full system verification will be conducted prior to re-enabling the bridge.
Posted Jul 21, 2025 - 13:11 UTC
This incident affected: Polygon Portal.