Mainnet heimdall halted

Incident Report for Polygon

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 11:01 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 30, 2025 - 09:57 UTC

Investigating

Date: July 30, 2025
Time: 02:30 AM UTC – Ongoing
Status: Fixing

Affected Services
Heimdall-V2 network

Summary
As of 09:30 AM UTC on July 30, 2025, the mainnet Heimdall service became unresponsive. The Polygon protocol team is currently investigating the issue. This affects the ability to view validator and checkpoint data via the mainnet Heimdall APIs.

Please note: This does not impact the Bor layer.

Maintenance Overview
Component: Mainnet Heimdall-V2 network

Issue: Service downtime detected;

Suspected Cause: Bug in consensus

Resolution ETA: Under investigation
Posted Jul 30, 2025 - 09:52 UTC
This incident affected: Polygon Mainnet (Mainnet Tendermint API, Mainnet Heimdall API).