Amoy Testnet – Erigon Performance Issue

Incident Report for Polygon

Resolved

We have release a new version (v3.3.1-beta3) for Erigon amoy that resolves the issue.
Posted Nov 21, 2025 - 16:25 UTC

Investigating

We have identified an issue with Erigon on Amoy Testnet, and users may currently experience some temporary impacts to RPC provider endpoint responses. We are working on an immediate fix and will provide updates here when this is resolved.
Posted Nov 21, 2025 - 12:27 UTC