Planned Migration – Heimdall V1 → V2

Incident Report for Polygon

Postmortem

Date: Thursday, July 10, 2025
Incident Window: 14:00 – 23:00 UTC
Status: Resolved
Affected Services:
portal.polygon.technology (User Portal)
staking.polygon.technology (Staking Dashboard)
heimdall-api.polygon.technology (Heimdall API)

Summary:
On July 10, 2025, Polygon Labs carried out a planned upgrade of the Heimdall layer from V1 to V2 as part of critical infrastructure modernization on the Polygon PoS chain. During the migration window from 14:00 UTC to 23:00 UTC, the Heimdall backend was temporarily halted, which caused downtime across multiple dependent services, including the user portal, staking dashboard, and Heimdall APIs. Polygon PoS block production remained unaffected during the incident. The Bor layer continued operating normally, ensuring that the network's transaction finality and liveness were maintained.

Technical Overview: The migration halted Heimdall at the last V1 checkpoint (~block 24,404,500), exported its state, and initialized Heimdall V2 with a new genesis. Validators upgraded their nodes, applied the migrated state, and restarted using Heimdall V2 binaries. During this process, services relying on Heimdall (e.g., Portal, Staking, API) were temporarily unavailable while syncing resumed. Bor continued block production uninterrupted.

Resolution: By 23:00 UTC, the following outcomes were achieved: Heimdall V2 was successfully deployed and synced across validators. All API and frontend services were restored. System monitoring confirmed full operational health. No data inconsistencies or validator issues were reported.

Root Cause: This was a planned migration, not a failure. Downtime was necessary to safely regenerate the Heimdall genesis and reinitialize all validator nodes with V2 logic. All changes followed the procedure defined in Heimdall V2 Migration Guide[https://github.com/0xPolygon/heimdall-v2/tree/75328ba18f9eb17c9bd3cc313c42c9eb379a433d/migration]

Posted Jul 17, 2025 - 16:13 UTC

Resolved

Heimdall V2 Migration
Posted Jul 10, 2025 - 14:00 UTC