Token Balance Issue on Polygon

Incident Report for Polygon

Resolved

We have resolved token balances not showing accurately in the UI due to a temporary issue on the Balance API on Polygon Portal. There were no impacts to network operations, and the UI is now reflecting all balances.
Posted Mar 07, 2026 - 14:25 UTC

Update

We are continuing to investigate this issue.
Posted Mar 07, 2026 - 14:01 UTC

Investigating

We are currently investigating an issue where token balances are not showing accurately in the UI due to a temporary issue with the Balance API on Polygon Portal. There are no impacts to network operations, and our team is working to restore the UI display of balances as soon as possible. Please note that users' funds are completely safe.
Posted Mar 07, 2026 - 13:59 UTC
This incident affected: Polygon Portal.